Guida online

Benvenuti nel nostro centro assistenza hosting.

Qui troverete istruzioni e informazioni utili sui nostri servizi e il vostro web hosting

Non esitate a contattarci se la vostra domanda non è rivolta qui - siamo qui per aiutare.

Categorie

Sottocategorie

Upgrade PHP 5.6 / 7.0 / 7.1 su 7.2

Ausgangslage

Veralteten PHP-Versionen werden von den Entwicklern von PHP nicht mehr offiziell unterstützt und auftauchende Sicherheitslücken nicht mehr behoben. Aus diesem Grund wird die Unterstützung für PHP 5.6 / 7.0 / 7.1 auf allen Servern per 01.12.2020 eingestellt und PHP auf die Version 7.2 aktualisiert. 

Gängige Web-Applikationen

Folgende Liste gibt Ihnen Auskunft darüber, welche Versionen von gängigen Web-Applikationen nicht mit PHP 7.2 kompatibel sind. In diesem Fall empfiehlt sich ein Upgrade der entsprechenden Applikation. Kontaktieren Sie dazu bitte Ihren Web-Verantwortlichen bzw. Ihre Agentur.

WordPress:
WordPress selbst ist ab Version 4.9.3 kompatibel, jedoch müssen auch alle Themes und Plugin's kompatibel sein.
Dies können Sie mit folgendem Plugin prüfen. Es scannt ihre Anwendung inklusive Themes und Plugins und zeigt auf, welche Komponenten für PHP 7.2 geeignet sind und welche aktualisiert werden müssen.

Typo3:
Ab Version 7.x kompatibel

Drupal:
Ab Version 8.2.6 kompatibel

Joomla:
Ab Version 3.9.x kompatibel, jedoch müssen auch alle Templates und Erweiterungen kompatibel sein

Magento:
Magento 1 und 2 sind kompatibel, jedoch muss der Patch "PHP 7.2 Support" installiert sein!

Contao:
Ab Version 3.5.5 kompatibel

PHP-Version selbst ändern

Sie können die PHP-Version in Ihrem Hosting jederzeit selbst anpassen. Hier finden Sie eine entsprechende Anleitung dazu. Es wird dringend empfohlen, die Version vor der Umstellung im Dezember mindestens zu Testzwecken anzupassen um zu prüfen, ob auch mit der neuen PHP-Version alles wie gewohnt funktioniert.

© 2022 webkeeper.ch

Made with in Switzerland